[odc] Daily ports changes for 2011-09-27

ODC auto at squish.net
Wed Sep 28 07:00:22 BST 2011


OpenBSD ports changes summary for 2011-09-27
============================================

audio/shell-fm                          databases/evolution-data-server
databases/postgresql                    devel
devel/atk                               devel/cvs2svn
devel/dconf                             devel/gconf2
devel/gdb                               devel/glib2
devel/glib2mm                           devel/leiningen
devel/libbfd                            devel/libpeas
devel/libsoup                           devel/msp430
devel/pangomm                           devel/pyflakes
graphics/evince                         graphics/simple-scan
infrastructure/lib                      lang/ocaml
lang/python                             mail/py-policyd-spf
misc/gramps                             net/glib2-networking
net/php-weathermap                      net/quagga
net/telepathy                           shells/zsh
sysutils/deja-dup                       sysutils/gamin
textproc/py-xml                         www/timetrex
x11/gnome                               x11/gtk3mm
x11/nx                                  

== audio ============================================================= 01/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/audio

shell-fm

  ~ patches/patch-source_sckif_c          

  > Align local patch with upstream; no bump needed. (dcoppa@)

== databases ========================================================= 02/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/databases

evolution-data-server

  ~ Makefile                              

  > - remove bogus configure arguments which lead to variables not being
  > initialized and substituted in Makefiles and pkgconfig files.
  > configure seems smart enough now to pickup nss/nspr by itself. (jasper@)

postgresql

  ~ Makefile                              ~ distinfo
  ~ pkg/PLIST-docs                        ~ pkg/PLIST-main

  TAGGED OPENBSD_5_0
  > Update to 9.0.5
  > Lot of bugfixes + CVE-2011-2483
  > ok ajacoutot@ (pea@)

  ~ Makefile                              ~ distinfo
  ~ pkg/PLIST-docs                        ~ pkg/PLIST-main

  TAGGED OPENBSD_4_9
  > Update to 9.0.5
  > Lot of bugfixes + CVE-2011-2483
  > ok ajacoutot@ (pea@)

== devel ============================================================= 03/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/devel

devel

  ~ Makefile                              

  > Remove devel/libbfd, nothing uses it now and if needed it can be taken
  > from devel/gdb.
  > ok avsm@ ckuethe@ dcoppa@ jasper@ (landry@)

  ~ Makefile                              

  > add devel/libbfd back in, devel/gdb build fails on amd64.
  > discussed with espie@ (sthen@)

atk

  ~ Makefile                              ~ distinfo

  > Update to stable atk-2.2.0. (ajacoutot@)

cvs2svn

  ~ Makefile                              

  > remove dreadful ${MODPY_RUN_DEPENDS:S/python/python-bsddb/} constructs now
  > we have PKGSPEC for Python and can do this properly. (sthen@)

dconf

  - patches/patch-bin_dconf-bash-completion_sh
  - patches/patch-bin_dconf_vala          
  - patches/patch-client_dconf-client_vala
  - patches/patch-common_dconf-shmdir_c   
  - patches/patch-editor_dconf-model_vala
  - patches/patch-editor_dconf-schema_vala
  ~ Makefile                              ~ distinfo
  ~ patches/patch-bin_Makefile_in         ~ patches/patch-client_Makefile_in
  ~ patches/patch-dbus-1_Makefile_in      ~ patches/patch-editor_Makefile_in
  ~ patches/patch-engine_dconf-engine_c   

  > Update to dconf-0.10.0. (ajacoutot@)

  ~ Makefile                              
  + patches/patch-editor_dconf-editor_desktop_in

  > Upstream does not provide a dconf-editor icon yet, so just use a gtk stock
  > one. (ajacoutot@)

gconf2

  - pkg/DESCR-gtk                         - pkg/PLIST-gtk
  ~ Makefile                              

  > Bye bye gconf-sanity-check-2... (ajacoutot@)

gdb

  ~ Makefile                              

  > mirror distfile (jasper@)

glib2

  ~ Makefile                              ~ distinfo
  ~ patches/patch-gio_gunixmounts_c       

  > Update to stable glib2-2.30.0. (ajacoutot@)

glib2mm

  ~ Makefile                              ~ distinfo
  ~ patches/patch-Makefile_in             ~ pkg/PLIST

  > Update to glib2mm-2.30.0. (ajacoutot@)

  ~ Makefile                              

  > Forgot to bump in previous. (ajacoutot@)

leiningen

  ~ Makefile                              ~ patches/patch-lein

  > - fix a path and zap bogus stuff from post-install. (jasper@)

libbfd

  - Makefile                              - distinfo
  - pkg/PLIST                             - pkg/DESCR

  > Remove devel/libbfd, nothing uses it now and if needed it can be taken
  > from devel/gdb.
  > ok avsm@ ckuethe@ dcoppa@ jasper@ (landry@)

  + Makefile                              + distinfo
  + pkg/DESCR                             + pkg/PLIST

  > add devel/libbfd back in, devel/gdb build fails on amd64.
  > discussed with espie@ (sthen@)

libpeas

  - patches/patch-libpeas_peas-object-module_c
  ~ Makefile                              ~ distinfo
  ~ pkg/PLIST                             

  > - update to 1.2.0 (jasper@)

libsoup

  - patches/patch-libsoup_soup-cache_c    
  - patches/patch-libsoup_soup-message-io_c
  ~ Makefile                              ~ distinfo
  ~ pkg/PLIST-main                        

  > Update to libsoup-2.36.0. (ajacoutot@)

msp430

  ~ binutils/Makefile                     ~ gcc/Makefile
  ~ libc/Makefile                         ~ msp430mcu/Makefile

  > sort PATCHFILES list (jasper@)

  ~ gcc/Makefile                          ~ gcc/distinfo

  > - roll in upstream patch to fix an issue with args being overwritten after
  > calls
  > involving int64 (jasper@)

pangomm

  ~ Makefile                              ~ distinfo
  ~ pkg/PLIST                             

  > Update to pangomm-2.28.3.
  > Make it use the gnome MODULE. (ajacoutot@)

pyflakes

  ~ Makefile                              ~ distinfo

  > Update to pyflakes 0.5.0
  > ok ajacoutot@ (mpi@)

== graphics ========================================================== 04/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/graphics

evince

  ~ Makefile                              ~ distinfo
  ~ pkg/PLIST-main                        

  > - update to 3.2.0 (jasper@)

simple-scan

  ~ Makefile                              ~ distinfo

  > Update to stable simple-scan-3.2.0. (ajacoutot@)

== infrastructure ==================================================== 05/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/infrastructure

lib

  ~ DPB/Fetch.pm                          

  > deal with suspend: connection may time out, so in case of failure, if
  > we got suspended, try the same site again. (espie@)

  ~ DPB/PkgPath.pm                        

  > fix build of "x11/qt3," : for multi-packages, when we find the default
  > subpackage, copy full options status. So, e.g., look for "x11/qt3,"
  > find "x11/qt3,,-main" and equate it with "x11/qt3," NOT "x11/qt3" (espie@)

== lang ============================================================== 06/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/lang

ocaml

  ~ Makefile                              

  > Switch ocaml to use the static libbfd.a from devel/gdb port now that
  > it's hooked up to the build on all archs. Tested on i386/amd64/sparc64.
  > ok avsm@ (maintainer) ckuethe@ dcoppa@ jasper@ (landry@)

  ~ Makefile                              

  > revert previous; devel/gdb broken on amd64 (sthen@)

python

  ~ Makefile.inc                          ~ python.port.mk
  ~ 2.4/Makefile                          ~ 2.5/Makefile
  ~ 2.7/Makefile                          ~ 3.2/Makefile

  > let Python use PKGSPEC infrastructure, discussed with and variable name
  > suggestion from fgsch@ (sthen@)

== mail ============================================================== 07/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/mail

py-policyd-spf

  ~ Makefile                              ~ distinfo
  ~ patches/patch-policyd-spf_1           ~ patches/patch-setup_py
  ~ pkg/PLIST                             

  > Update to version 0.8.1
  > maintainer pea@ timed-out
  > ok sthen@ (giovanni@)

== misc ============================================================== 08/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/misc

gramps

  ~ Makefile                              

  > remove dreadful ${MODPY_RUN_DEPENDS:S/python/python-bsddb/} constructs now
  > we have PKGSPEC for Python and can do this properly. (sthen@)

== net =============================================================== 09/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/net

glib2-networking

  ~ Makefile                              ~ distinfo
  ~ pkg/PLIST                             

  > Update to glib2-networking-2.30.0. (ajacoutot@)

php-weathermap

  ~ Makefile                              

  > ${LOCALBASE}/bin/php is no good any more, use MODPHP_BIN (sthen@)

  ~ Makefile                              
  + patches/patch-editor-config_php-dist
  + patches/patch-editor_inc_php          + patches/patch-editor_php
  + patches/patch-lib_datasources_WeatherMapDataSource_mrtg_php

  > Add a few patches to php-weathermap, making the editor easier to handle.
  > (sthen@)

quagga

  - patches/patch-bgpd_bgp_attr_c         - patches/patch-ospfd_ospf_lsa_h
  - patches/patch-ospfd_ospf_nsm_c        - patches/patch-ospfd_ospf_opaque_c
  - patches/patch-ospfd_ospf_opaque_h     ~ Makefile
  ~ distinfo                              ~ patches/patch-doc_Makefile_in
  ~ patches/patch-ospfclient_Makefile_in
  ~ pkg/DESCR                             ~ pkg/PFRAG.shared
  ~ pkg/PLIST                             

  > SECURITY update to quagga 0.99.19
  > CVE-2011-3323: ospf6d *stack-based buffer overflow*, inter-area-prefix LSAs
  > CVE-2011-3324: ospf6d assertion failure; DD LSAs with over-length header
  > CVE-2011-3325: ospf crash(?) if a hello has a truncated header or invalid
  > type
  > CVE-2011-3326: ospf null deref if a link state update LSA has an unknown
  > type
  > CVE-2011-3327: bgp buffer overflow with malformed UPDATE (extended
  > communities) (sthen@)

  - patches/patch-bgpd_bgp_attr_c         - patches/patch-ospfd_ospf_lsa_h
  - patches/patch-ospfd_ospf_nsm_c        - patches/patch-ospfd_ospf_opaque_c
  - patches/patch-ospfd_ospf_opaque_h     ~ Makefile
  ~ distinfo                              ~ patches/patch-doc_Makefile_in
  ~ patches/patch-ospfclient_Makefile_in
  ~ pkg/DESCR                             ~ pkg/PFRAG.shared
  ~ pkg/PLIST                             

  TAGGED OPENBSD_5_0
  > MFC: SECURITY update to quagga 0.99.19
  > CVE-2011-3323: ospf6d *stack-based buffer overflow*, inter-area-prefix LSAs
  > CVE-2011-3324: ospf6d assertion failure; DD LSAs with over-length header
  > CVE-2011-3325: ospf crash(?) if a hello has a truncated header or invalid
  > type
  > CVE-2011-3326: ospf null deref if a link state update LSA has an unknown
  > type
  > CVE-2011-3327: bgp buffer overflow with malformed UPDATE (extended
  > communities) (sthen@)

telepathy

  ~ folks/Makefile                        ~ folks/distinfo

  > - updatet to 0.6.3.2 (jasper@)

== shells ============================================================ 10/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/shells

zsh

  ~ Makefile                              ~ pkg/PLIST
  + patches/patch-Completion_compinit     

  > Fix completion when ksh_arrays is set.
  > Spotted by Christopher Zimmermann <madroach at zakweb.de>, thanks !
  > ok ajacoutot@ (pea@)

== sysutils ========================================================== 11/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/sysutils

deja-dup

  ~ Makefile                              ~ distinfo
  ~ pkg/PLIST                             

  > Update to deja-dup-20.0. (ajacoutot@)

gamin

  - pkg/MESSAGE-server                    ~ Makefile
  ~ pkg/PLIST-server                      + pkg/README-server

  > MESSAGE -> README. (ajacoutot@)

== textproc ========================================================== 12/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/textproc

py-xml

  ~ Makefile                              

  > remove dreadful ${MODPY_RUN_DEPENDS:S/python/python-bsddb/} constructs now
  > we have PKGSPEC for Python and can do this properly. (sthen@)

== www =============================================================== 13/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/www

timetrex

  ~ Makefile                              
  ~ patches/patch-timetrex_ini_php-example_linux

  > ${LOCALBASE}/bin/php is no good any more, use MODPHP_BIN (sthen@)

== x11 =============================================================== 14/14 ==

  http://www.openbsd.org/cgi-bin/cvsweb/ports/x11

gnome

  ~ at-spi2-core/Makefile                 ~ at-spi2-core/distinfo
  ~ at-spi2-core/pkg/PLIST                

  > Update to at-spi2-core-2.2.0. (ajacoutot@)

  ~ at-spi2-atk/Makefile                  ~ at-spi2-atk/distinfo
  ~ at-spi2-atk/pkg/PLIST                 

  > Update to at-spi2-atk-2.2.0. (ajacoutot@)

  ~ py-atspi/Makefile                     ~ py-atspi/distinfo

  > Update to py-atspi-2.2.0. (ajacoutot@)

  - gcalctool/patches/patch-src_math-equation_c
  ~ gcalctool/Makefile                    ~ gcalctool/distinfo

  > - update to 6.2.0 (jasper@)

  ~ user-docs/Makefile                    ~ user-docs/distinfo
  ~ user-docs/pkg/PLIST                   

  > - update to 3.2.0 (jasper@)

  ~ devel-docs/Makefile                   ~ devel-docs/distinfo
  ~ devel-docs/pkg/PLIST                  

  > - update to 3.2.0 (jasper@)

  ~ user-docs/Makefile                    

  > - model a bit more after devel-docs (jasper@)

  ~ user-docs/Makefile                    ~ devel-docs/Makefile

  > add missing build dependency (jasper@)

  ~ yelp-xsl/Makefile                     ~ yelp-xsl/distinfo
  ~ yelp-xsl/pkg/PLIST                    + yelp-xsl/patches/patch-Makefile_in

  > Update to yelp-xsl-3.2.0. (ajacoutot@)

  ~ yelp-xsl/Makefile                     ~ yelp-xsl/pkg/PLIST

  > Tweak DEPENDS. (ajacoutot@)

  ~ eog/Makefile                          ~ eog/distinfo
  ~ eog/pkg/PLIST                         

  > - update to 3.2.0 (jasper@)

  - yelp/patches/patch-libyelp_yelp-man-parser_c
  - yelp/patches/patch-libyelp_yelp-uri_c
  ~ yelp/Makefile                         ~ yelp/distinfo
  ~ yelp/pkg/PLIST                        + yelp/patches/patch-configure

  > Update to yelp-3.2.0. (ajacoutot@)

  ~ eog-plugins/Makefile                  ~ eog-plugins/distinfo
  ~ eog-plugins/pkg/PLIST                 
  + eog-plugins/patches/patch-configure_ac

  > - update to 3.2.0 (jasper@)

  - krb5-auth-dialog/patches/patch-src_ka-dialog_c
  ~ krb5-auth-dialog/Makefile             ~ krb5-auth-dialog/distinfo
  ~ krb5-auth-dialog/pkg/PLIST            
  + krb5-auth-dialog/patches/patch-src_ka-kerberos_c

  > Update to krb5-auth-dialog-3.2.0. (ajacoutot@)

  ~ session/Makefile                      

  > No need for gconf2-sanity-check anymore. (ajacoutot@)

  ~ settings-daemon/Makefile              ~ settings-daemon/distinfo
  ~ settings-daemon/pkg/PLIST             
  + settings-daemon/patches/patch-configure
  + settings-daemon/patches/patch-plugins_Makefile_in
  + settings-daemon/patches/patch-plugins_power_gsd-backlight-helper_c
  + settings-daemon/patches/patch-plugins_print-notifications_gsd-printer_c

  > Update to gnome-settings-daemon-3.2.0. (ajacoutot@)

  - menus/patches/patch-Makefile_in       ~ menus/Makefile
  ~ menus/pkg/PLIST                       
  + menus/pkg/patch-simple-editor_GMenuSimpleEditor_main_py
  + menus/pkg/patch-simple-editor_GMenuSimpleEditor_menufilewriter_py
  + menus/pkg/patch-simple-editor_GMenuSimpleEditor_menutreemodel_py

  > add patches from upstream to fix gmenu-simple-editor (jasper@)

  ~ zenity/Makefile                       ~ zenity/distinfo
  ~ zenity/patches/patch-src_tree_c       ~ zenity/pkg/PLIST

  > - update to 3.2.0 (jasper@)

  ~ session/Makefile                      ~ session/pkg/README

  > No more alacarte. (ajacoutot@)

  - alacarte/Makefile                     - alacarte/distinfo
  - alacarte/patches/patch-Alacarte_MainWindow_py
  - alacarte/patches/patch-Alacarte_MenuEditor_py
  - alacarte/patches/patch-Alacarte_util_py
  - alacarte/patches/patch-data_alacarte_desktop_in_in
  - alacarte/pkg/DESCR                    - alacarte/pkg/PLIST

  > remove, this app is broken and deprecated in several ways:
  > - still hasn't been ported to the new libgnome-menus api
  > - hasn't had a real release in two years
  > - uses old pygobject2 with pygi support, which has been moved to
  > py-gobject3 to facilitate other development in the tree.
  > (at least gmenu-simple-editor works again..)
  > as discussed with aja@ (jasper@)

  ~ Makefile                              

  > sync (jasper@)

  ~ gnome.port.mk                         

  > Add a BUILD_DEPENDS on textproc/itstool in the MODGNOME_TOOLS "yelp"
  > case. This is likely to become needed more and more (itstool is the
  > successor to xml2po).
  > ok jasper@ (ajacoutot@)

  ~ user-docs/Makefile                    

  > Dependency taken care of by MODGNOME_TOOLS yelp. (ajacoutot@)

  ~ icon-theme-symbolic/Makefile          ~ icon-theme-symbolic/distinfo
  ~ icon-theme-symbolic/pkg/PLIST         

  > Update to gnome-icon-theme-symbolic-3.2.0. (ajacoutot@)

  - controlcenter/patches/patch-libgnome-control-center_Makefile_in
  - controlcenter/patches/patch-panels_keyboard_cc-keyboard-item_c
  - controlcenter/patches/patch-panels_printers_pp-utils_c
  ~ controlcenter/Makefile                ~ controlcenter/distinfo
  ~ controlcenter/patches/patch-panels_common_Makefile_in
  ~ controlcenter/patches/patch-panels_common_gdm-languages_c
  ~ controlcenter/patches/patch-panels_datetime_datetime_ui
  ~ controlcenter/patches/patch-panels_info_cc-info-panel_c
  ~ controlcenter/patches/patch-panels_printers_cc-printers-panel_c
  ~ controlcenter/patches/patch-panels_printers_pp-new-printer-dialog_c
  ~ controlcenter/patches/patch-panels_user-accounts_Makefile_in
  ~ controlcenter/pkg/PLIST               
  + controlcenter/patches/patch-configure
  + controlcenter/patches/patch-panels_Makefile_in
  + controlcenter/patches/patch-panels_info_hostnames-test_txt
  + controlcenter/patches/patch-panels_region_gnome-region-panel-formats_c

  > Update to gnome-control-center-3.2.0. (ajacoutot@)

  ~ orca/Makefile                         ~ orca/distinfo
  ~ orca/pkg/PLIST                        

  > Update to orca-3.2.0. (ajacoutot@)

  ~ rygel/Makefile                        ~ rygel/distinfo

  > - update to 0.12.3 (jasper@)

  ~ icon-theme/Makefile                   ~ icon-theme/distinfo
  ~ icon-theme/pkg/PLIST                  

  > - update to 3.2.0 (jasper@)

  ~ online-accounts/Makefile              

  > Add a HOMEPAGE. (ajacoutot@)

  ~ settings-daemon/patches/patch-configure

  > No need to check for lcms2 until we have colord; spotted by jasper@
  > (ajacoutot@)

  ~ themes-standard/Makefile              ~ themes-standard/distinfo

  > Minor update to gnome-themes-standard-3.2.0.1. (ajacoutot@)

  ~ orca/Makefile                         

  > Missing BUILD_DEPENDS. (ajacoutot@)

  ~ controlcenter/Makefile                

  > tighten dependency on gsettings-desktop-schemas (jasper@)

  - gjs/patches/patch-gjs_context_c       - gjs/patches/patch-gjs_context_h
  ~ gjs/Makefile                          ~ gjs/distinfo
  + gjs/patches/patch-gi_object_c         

  > - update to 1.30.0 (jasper@)

  ~ gitg/Makefile                         ~ gitg/distinfo

  > - update to 0.2.5 (jasper@)

  ~ online-accounts/Makefile              

  > disable all providers but google, they aren't ready for consumption yet.
  > as pointed out by upstream (jasper@)

  ~ libgnomekbd/Makefile                  ~ libgnomekbd/distinfo
  ~ libgnomekbd/pkg/PLIST                 

  > Update to libgnomekbd-3.2.0. (ajacoutot@)

gtk3mm

  ~ Makefile                              ~ distinfo
  ~ pkg/PLIST                             

  > Update to gtk3mm-3.2.0. (ajacoutot@)

  ~ Makefile                              

  > Missing WANTLIB block. (ajacoutot@)

nx

  - opennx/pkg/MESSAGE                    ~ opennx/Makefile
  ~ opennx/pkg/PLIST                      + opennx/pkg/README

  > MESSAGE -> README. (jasper@)

  ~ opennx/Makefile                       ~ opennx/pkg/README

  > bleh, missing rcs id (jasper@)

===============================================================================


More information about the odc mailing list